Support Line/Chat Unavailable
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 7 months ago. May 10, 2018 - 08:44 MST
Monitoring
Our 3rd party vendor Zendesk provider has implemented a fix for our phone and chat systems and we are monitoring the results.
Posted 7 months ago. May 10, 2018 - 08:40 MST
Identified
Our Phone/Chat service provider is currently experiencing an issue that is preventing customers from reaching our support line and chat services. We will update here as soon as we receive additional information from our provider.
Posted 7 months ago. May 10, 2018 - 06:55 MST
Investigating
We are currently investigating this issue.
Posted 7 months ago. May 10, 2018 - 05:11 MST
This incident affected: General Edgenuity Systems (Edgenuity support line).