Sis Login
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 14, 2019 - 11:25 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jul 14, 2019 - 10:12 EDT
Update
As a workaround, users trying to use Genius please use the link below to be able to login to your Genius SIS platform. We appreciate your patience as we continue to work on the present issue.

Workaround Link: https://e2020.geniussis.com/
Posted about 1 month ago. Jul 14, 2019 - 10:04 EDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Jul 14, 2019 - 09:45 EDT
This incident affected: Student and Educator Systems (Genius/SIS).