Odysseyware Dashboard Refresh Date Not Current
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jul 26, 2021 - 14:24 MST
Identified
The Odysseyware platforms are currently experiencing degraded performance.

Some educators may see the Reports Dashboard Refresh Date is not current.

Our Operations team has identified the issue and is currently implementing a solution. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Jul 26, 2021 - 09:49 MST
This incident affected: Student and Educator Systems (Odysseyware LMS).