Genius SIS Password Reset
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 21, 2019 - 23:26 EDT
Investigating
An issue has been identified with users in Genius SIS being unable to reset their password. This is a known issue that will be addressed tonight August 21th, 2019. If you have any questions please contact our support team at customersupport@edgenuity.com
Posted about 2 months ago. Aug 21, 2019 - 14:20 EDT