Phone System
Incident Report for status.edgenuity.com
Resolved
Our 3rd party vendor Zendesk was able to resolve this issue; our customer support team is now able to receive phone calls.
Posted 3 months ago. Jun 24, 2019 - 09:27 EDT
Identified
Our 3rd party vendor Zendesk has escalated this event, now indicating degraded performance with their call feature affecting customer support calls intermittently.
Posted 3 months ago. Jun 24, 2019 - 08:56 EDT
Investigating
We are currently investigating an issue where users are unable to connect calls to our customer support.
Posted 3 months ago. Jun 24, 2019 - 08:35 EDT
This incident affected: General Edgenuity Systems (Edgenuity support line).