Edgenuity LMS Slowness
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Apr 07, 2020 - 12:34 MST
Investigating
We are currently investigating this issue.
Posted Apr 07, 2020 - 11:01 MST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS).