Edgenuity Courseware Activities & Group Progress Reports
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 17:26 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2020 - 16:50 MST
Identified
We have been made aware that some students are having difficulty completing activities in Edgenuity Courseware. If students are having trouble loading activities, please try clearing the browser cache.
You can find instructions for various browsers here.

If you still need support, our support department can be reached at customersupport@edgenuity.com

In addition, some customers are experiencing issues with Group Progress reports. We are actively working on this issue.
Posted Jun 19, 2020 - 11:37 MST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS, LMS feature/tool).