Edgenuity LMS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 6 months ago. May 03, 2018 - 20:59 MST
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. May 03, 2018 - 20:05 MST
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted 6 months ago. May 03, 2018 - 19:09 MST