Zendesk Chat
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 10:46 MST
Investigating
We are currently investigating an issue with our customer support chat feature.
Posted Oct 22, 2019 - 10:04 MST
This incident affected: General Edgenuity Systems (Edgenuity chat service).