Edgenuity's instance of Genius SIS unavailable
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 05:58 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2020 - 05:45 MST
Investigating
We are currently investigating this issue.
Posted Sep 10, 2020 - 05:29 MST
This incident affected: Student and Educator Systems (Genius/SIS).