Edgenuity Courseware Unexpected Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 18:39 MST
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted Jul 22, 2020 - 18:25 MST
This incident affected: Student and Educator Systems (Edgenuity Student LMS).